Symfony News

Symfony 5.1.7 released

WARNING: This version might break your application if you’ve already updated your dependencies to the latest patch versions and if you started using the new src/preload.php file. Unfortunately, we quickly discovered that it was a problem for many users just after the release, so we’ve then decided to revert it in favor of a config.preload.php file generated via a recipe. To upgrade, remove the src/preload.php file and create a config/preload.php file with the contents from the recipe depending on your version.

Symfony 5.1.7 has just been released. Here is a list of the most important changes:

  • bug #38396 Handle consecutive supports() calls in the RememberMeAuthenticator (@wouterj)
  • bug #36291 [Lock] Fix StoreFactory to accept same DSN syntax as AbstractAdapter (@Jontsa)
  • bug #38390 [Serializer][Minor] Fix circular reference exception message (bad limit displayed) (@l-vo)
  • bug #38388 [HttpClient] Always “buffer” empty responses (@nicolas-grekas)
  • bug #38384 [PhpUnitBridge] Fix Deprecation file when it comes from the TestsListener (@fancyweb)
  • bug #38380 [Form] propagate validation groups to subforms (@johanderuijter, @xabbuh)
  • bug #38377 Ignore more deprecations for Mockery mocks (@fancyweb)
  • bug #38375 [HttpClient] fix using proxies with NativeHttpClient (@nicolas-grekas)
  • bug #38372 [Routing] fix using !important and defaults/reqs in inline route definitions (@nicolas-grekas)
  • bug #38373 [ErrorHandler][DebugClassLoader] Do not check Mockery mocks classes (@fancyweb)
  • bug #38368 [HttpClient] Fix using https with proxies (@bohanyang)
  • bug #38350 [TwigBundle] Only remove kernel exception listener if twig is used (@dmolineus)
  • bug #38360 [BrowserKit] Cookie expiration at current timestamp (@iquito)
  • bug #38357 [DI] fix dumping non-shared lazy services (@nicolas-grekas)
  • bug #38358 [Messenger] Fix redis connection error message (@alexander-schranz)
  • bug #38343 Revert “bug #38063 [FrameworkBundle] generate preload.php in src/ to make opcache.preload predictable” (@nicolas-grekas)
  • bug #38348 [FrameworkBundle] Add Mailjet definition (@michaelKaefer)
  • bug #38336 [PhpUnitBridge] Fixed clas _alias() for PHPUnitFrameworkErrorError (@stevegrunwell)

Want to upgrade to this new release? Because Symfony protects backwards-compatibility very closely, this should be quite easy. Use SymfonyInsight upgrade reports to detect the code you will need to change in your project and read our upgrade documentation to learn more.

Want to be notified whenever a new Symfony release is published? Or when a version is not maintained anymore? Or only when a security issue is fixed? Consider subscribing to the Symfony Roadmap Notifications.


Sponsor the Symfony project.


About us

What a Symfony developer should know about the framework: News, Jobs, Tweets, Events, Videos,...

Find us on Twitter

Find us on Facebook

ADS